Exempel 3

I detta exempel undersöks olika typer av statiska rutter. Det finns flera varianter beroende på behov och konfiguration.

Typer av statiska rutter

  • Standard Static Route (next-hop)
    • ip route <destinationens nätverksadress och nätmask> <next-hop-router IP>
  • Directly Connected Route
    • ip route <destinationens nätverksadress och nätmask> <exit interface>
  • Fully Specified Static Route
    • ip route <destinationens nätverksadress och nätmask> <exit interface> <next-hop-router IP>
  • Default Static Route
    • ip route 0.0.0.0 0.0.0.0 <next-hop-router IP>
    • ip route 0.0.0.0 0.0.0.0 <exit interface>
  • Floating Static Route
    • ip route <destinationens nätverksadress och nätmask> <next-hop-router IP> <administrativt avstånd större än 1 >
    • ip route <destinationens nätverksadress och nätmask> <exit interface> <administrativt avstånd större än 1 >
  • Summary Static Route
    • ip route <aggregerad destinationens nätverksadress och nätmask> <next-hop-router IP>

Nätverkstopologi

Nätverket består av fem routrar av modellen 2811, tre switchar av modellen 2960, samt fyra servrar och tre datorer.

Nedan beskrivs de olika enheternas roller:

  • R1
    • DHCP Relay Agent
    • Default route mot R2
  • R2
    • DCE-länk mot R4 med 128000 kbps (överföringshastighet i kilo bitar per sekund)
    • Summary route mot R1 som ger åtkomst till LAN Clients
    • 172.23.1.0 /27 och 172.23.1.32 /29 aggregeras till 172.23.1.0 /26
    • Standar route mot R3 som ger åtkomst till LAN Google
    • Floating route mot R4 som ger en reserv väg till LAN Google
  • R3
    • Standard route mot R2 som ger åtkomst till LAN Clients
    • Standard route mot R5 som ger åtkomst till LAN Google
  • R4
    • DCE-länk mot R5 med 128000 kbps (överföringshastighet i kilo bitar per sekund)
    • Standard route mot R1 som ger åtkomst till LAN Clients
    • Standard route mot R5 som ger åtkomst till LAN Google
  • R5
    • Default route mot R3 som ger åtkomst till LAN Clients
    • Default route mot R4 konfigurerad som Floating route
  • DNS Server
    • NS record: definierar namnservern för domänen diginto.se, där ns1.diginto.se fungerar som primär DNS-server
    • A record:  Anger IP-adresser för viktiga resurser:
      • ns1.diginto.se (172.23.1.35 /29)
      • www.diginto.se som pekar på File Server (172.23.1.36 /29)
      • www.google.com som pekar på Google server (8.8.8.8 /28)
  • File Server
    • File server är en webb-server som kör hemsidan www.diginto.se
  • DHCP Server
    • DHCP servern ansvarar för att dynamiskt tilldela IP-konfigurationer till klienter i LAN 172.23.1.0/27 (LAN Clients), inklusive IP-adress, nätmask, default gateway och DNS-information.

Konfigurationer

  • Grundläggande konfigurationer
  • Router> enable
  • Router# configure terminal
  • Router(config)# hostname R1
  • R1(config)# no ip domain-lookup
  • R1(config)# interface fa0/0
  • R1(config-if)# description Connected to SW1
  • R1(config-if)# ip address 172.23.1.1 255.255.255.224
  • R1(config-if)# no shutdown
  • DHCP Relay Agent konfiguration
  • R1(config-if)# ip helper-address 172.23.1.37
  • R1(config-if)# exit
  • R1(config)# interface fa1/0
  • R1(config-if)# description Connected to SW2
  • R1(config-if)# ip address 172.23.1.33 255.255.255.248
    R1(config-if)# no shutdown
  • R1(config-if)# exit
  • R1(config)# interface fa2/0
  • R1(config-if)# description Connected to R2
  • R1(config-if)# ip address 192.0.2.1 255.255.255.252
  • R1(config-if)# no shutdown
  • R1(config-if)# exit
  • Routing med statisk Default route
  • R1(config)# ip route 0.0.0.0 0.0.0.0 192.0.2.2
  • R1(config)# end
  • Ta fram en sammanfattning av IP-adressering
  • R1# show ip interface brief
  • Kontrollera hela konfigurationen
  • R1# show running-config
  • Grundläggande konfigurationer
  • Router> enable
  • Router# configure terminal
  • Router(config)# hostname R2
  • R2(config)# no ip domain-lookup
  • R2(config)# interface fa0/0
  • R2(config-if)# description Connected to R1
  • R2(config-if)# ip address 192.0.2.2 255.255.255.252
  • R2(config-if)# no shutdown
  • R2(config-if)# exit
  • R2(config)# interface fa0/1
  • R2(config-if)# description Connected to R3
  • R2(config-if)# ip address 198.51.100.5 255.255.255.252
  • R2(config-if)# no shutdown
  • R2(config-if)# exit
  • R2(config)# interface s0/0/0
  • R2(config-if)# description DCE Connected to R4
  • R2(config-if)# clock rate 128000
  • R2(config-if)# ip address 198.51.100.9 255.255.255.252
  • R2(config-if)# no shutdown
  • R2(config-if)# exit
  • Routing med statiska Standard route
  • R2(config)#ip route 172.23.1.0 255.255.255.192 192.0.2.1
  • R2(config)#ip route 8.8.8.0 255.255.255.240 198.51.100.6
  • Routing med statiska Standard route som floating point route
  • R2(config)#ip route 8.8.8.0 255.255.255.240 198.51.100.10 5
  • R2(config)#end
  • Ta fram en sammanfattning av IP-adressering
  • R2# show ip interface brief
  • Kontrollera hela konfigurationen
  • R2# show running-config
  • Grundläggande konfigurationer
  • Router>
  • Router>enable
  • Router#configure terminal
  • Router(config)#hostname R3
  • R3(config)#no ip domain-lookup
  • R3(config)#interface fa0/1
  • R3(config-if)#description Connected to R2
  • R3(config-if)#ip address 198.51.100.6 255.255.255.252
  • R3(config-if)#no shutdown
  • R3(config-if)#exit
  • R3(config)#interface fa0/0
  • R3(config-if)#description Connected to R5
  • R3(config-if)#ip address 203.0.113.1 255.255.255.252
  • R3(config-if)#no shutdown
  • R3(config-if)#exit
  • Standard route
  • R3(config)#ip route 172.23.1.0 255.255.255.192 198.51.100.5
  • R3(config)#ip route 8.8.8.0 255.255.255.240 203.0.113.2
  • R3(config)#end
  • Ta fram en sammanfattning av IP-adressering
  • R3# show ip interface brief
  • Kontrollera hela konfigurationen
  • R3# show running-config
  • Grundläggande konfigurationer
  • Router> enable
  • Router# configure terminal
  • Router(config)# hostname R4
  • R4(config)# no ip domain-lookup
  • R4(config)# interface s0/0/0
  • R4(config-if)# description Connected to R2
  • R4(config-if)# ip address 198.51.100.10 255.255.255.252
  • R4(config-if)# no shutdown
  • R4(config-if)# exit
  • R4(config)# interface s0/0/1
  • R4(config-if)# description DCE Connected to R5
  • R4(config-if)# clock rate 128000
  • R4(config-if)# ip address 203.0.113.5 255.255.255.252
  • R4(config-if)# no shutdown
  • R4(config-if)# exit
  • Routing med statiska Standard route
  • R4(config)# ip route 8.8.8.0 255.255.255.240 203.0.113.6
  • R4(config)# ip route 172.23.1.0 255.255.255.192 198.51.100.5
  • R4(config)# end
  • Ta fram en sammanfattning av IP-adressering
  • R4# show ip interface brief
  • Kontrollera hela konfigurationen
  • R4# show running-config
  • Grundläggande konfigurationer
  • Router> enable
  • Router# configure terminal
  • Router(config)# hostname R5
  • R5(config)# no ip domain-lookup
  • R5(config)# interface fa0/1
  • R5(config-if)# description Connected to R3
  • R5(config-if)# ip address 203.0.113.2 255.255.255.252
  • R5(config-if)# no shutdown
  • R5(config-if)# exit
  • R5(config)# interface s0/0/0
  • R5(config-if)# description Connected to R4
  • R5(config-if)# ip address 203.0.113.6 255.255.255.252
  • R5(config-if)# no shutdown
  • R5(config-if)# exit
  • R5(config)# interface fa0/0
  • R5(config-if)# description Connected to SW3
  • R5(config-if)# ip address 8.8.8.1 255.255.255.240
  • R5(config-if)# no shutdown
  • R5(config-if)# exit
  • Routing med statisk Default route
  • R5(config)#ip route 0.0.0.0 0.0.0.0 203.0.113.1
  • Routing med statisk Default route som Floating route
  • R5(config)#ip route 0.0.0.0 0.0.0.0 203.0.113.5 5
  • R5(config)#end
  • R5#