E-topologi

Detta är ett exempel inför det muntliga redovisningen. Två bilder används för att beskriva det vänstra och högra nätverk.

Konfigureringar

Alla konfigurationer har gjorts i enlighet med topologin (se ovan) och kan skilja sig från liknande topologier vi jobbade i skolan.

MGR1 konfigureringar

  • Router>enable
  • Router#configure terminal
  • Router(config)#hostname MGR1
  • MGR1(config)#interface g0/0
  • MGR1(config-if)#description LAN MG-1
  • MGR1(config-if)#ip address 192.168.0.65 255.255.255.192
  • MGR1(config-if)#no shutdown
  • MGR1(config-if)#exit
  • MGR1(config)#interface g0/1
  • MGR1(config-if)#description LAN MG-2
  • MGR1(config-if)#ip address 192.168.0.129 255.255.255.192
  • MGR1(config-if)#exit
  • MGR1(config-)#interface s0/0/0
  • MGR1(config-if)#description Connected to EDGER1
  • MGR1(config-if)#ip address 192.168.0.1 255.255.255.252
  • MGR1(config-if)#no shutdown
  • MGR1(config-if)#exit
  • MGR1(config)#ip route 0.0.0.0 0.0.0.0 192.168.0.2
  • MGR1(config)#end
  • MGR1#show ip interface brief
  • MGR1#show run
  • MGR1#copy running-config startup-config

MGR2 konfigureringar

  • Router>enable
  • Router#configure terminal
  • Router(config)#hostname MGR2
  • MGR2(config)#interface g0/0
  • MGR2(config-if)#description LAN MG core
  • MGR2(config-if)#ip address 192.168.1.65 255.255.255.192
  • MGR2(config-if)#no shutdown
  • MGR2(config-if)#exit
  • MGR2(config)#interface g0/1
  • MGR2(config-if)#description LAN MG-3
  • MGR2(config-if)#ip address 192.168.1.129 255.255.255.192
  • MGR2(config-if)#exit
  • MGR2(config)#interface s0/0/1
  • MGR2(config-if)#description Connected to EDGER1
  • MGR2(config-if)#ip address 192.168.1.1 255.255.255.252
  • MGR2(config-if)#no shutdown
  • MGR2(config-if)#exit
  • MGR2(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.2
  • MGR2(config)#end
  • MGR2#show ip interface brief
  • MGR2#copy running-config startup-config

EDGER1 konfigureringar

  • Router>enable
  • Router#configure terminal
  • Router(config)#hostname EDGER1
  • EDGER1(config)#interface s0/0/0
  • EDGER1(config-if)#description DCE Connected to MGR1
  • EDGER1(config-if)#clock rate 128000
  • EDGER1(config-if)#ip address 192.168.0.2 255.255.255.252
  • EDGER1(config-if)#no shutdown
  • EDGER1(config-if)#exit
  • EDGER1(config)#interface s0/0/1
  • EDGER1(config-if)#description DCE Connected to MGR2
  • EDGER1(config-if)#clock rate 128000
  • EDGER1(config-if)#ip address 192.168.1.2 255.255.255.252
  • EDGER1(config-if)#no shutdown
  • EDGER1(config-if)#exit
  • EDGER1(config)#interface s0/1/0
  • EDGER1(config-if)#description DCE Connected to EDGER2
  • EDGER1(config-if)#clock rate 128000
  • EDGER1(config-if)#ip address 201.65.1.2 255.255.255.252
  • EDGER1(config-if)#no shutdown
  • EDGER1(config-if)#exit
  • EDGER1(config)#ip route 192.168.0.64 255.255.255.0 192.168.0.1
  • EDGER1(config)#ip route 192.168.0.128 255.255.255.0 192.168.0.1
  • EDGER1(config)#ip route 192.168.1.64 255.255.255.0 192.168.0.1
  • EDGER1(config)#ip route 192.168.1.128 255.255.255.0 192.168.0.1
  • EDGER1(config)#ip route 17.16.5.0 255.255.255.252 201.65.1.1
  • EDGER1(config)#ip route 17.16.5.128 255.255.255.252 201.65.1.1
  • EDGER1(config)#ip route 172.16.5.0 255.255.255.128 201.65.1.1
  • EDGER1(config)#ip route 172.16.5.128 255.255.255.128 201.65.1.1
  • EDGER1(config)#end
  • EDGER1#show ip interface brief
  • EDGER1#copy running-config startup-config

DHCP server och klienter

  • MGR2(config)#ip dhcp excluded-address 192.168.0.65
  • MGR2(config)#ip dhcp excluded-address 192.168.0.129
  • MGR2(config)#ip dhcp excluded-address 192.168.1.129
  • MGR2(config)#ip dhcp pool MG-1
  • MGR2(dhcp-config)#network 192.168.0.64 255.255.255.192
  • MGR2(dhcp-config)#default-router 192.168.0.65
  • MGR2(dhcp-config)#dns-server 192.168.1.66
  • MGR2(dhcp-config)#domain-name mg.se
  • MGR2(dhcp-config)#exit
  • MGR2(config)#ip dhcp pool MG-2
  • MGR2(dhcp-config)#network 192.168.0.128 255.255.255.192
  • MGR2(dhcp-config)#default-router 192.168.0.129
  • MGR2(dhcp-config)#dns-server 192.168.1.66
  • MGR2(dhcp-config)#domain-name mg.se
  • MGR2(dhcp-config)#exit
  • MGR2(config)#ip dhcp pool MG-3
  • MGR2(dhcp-config)#network 192.168.1.128 255.255.255.192
  • MGR2(dhcp-config)#default-router 192.168.1.129
  • MGR2(dhcp-config)#dns-server 192.168.1.66
  • MGR2(dhcp-config)#domain-name mg.se
  • MGR2(dhcp-config)#exit
  • MGR2(config)#
  • MGR1 konfigureras som Relay DHCP
  • MGR1(config)#interface g0/0
  • MGR1(config-if)#ip helper-address 192.168.1.1
  • MGR1(config-if)#exit
  • MGR1(config)#interface g0/1
  • MGR1(config-if)#ip helper-address 192.168.1.1
  • MGR1(config-if)#exit
  • MGR1(config)#