Nätverkstjänster

I Applikationsskiktet beskrivs alla nödvändiga funktioner i olika server-applikationer som kan användas till att tillhandahålla tjänster åt sina klienter. Alla gången vi pratar om nätverk så har vi i åtanke TCP/IP kommunikationsmodeller även om det inte nämns. Applikationsskiktet omfattar OSI:s Applikation, Presentation och Session. I dessa skikten specificeras alla nätverkstjänster som tillhandahålls i ett server-klient nätverk (Internet).

Bild 1: OSI och TCP/IP kommunikationsmodeller

Ciscos Packet Tracer laborationer är upplagda med pedagogiska mål och syfte. Men inte alla laborationer passar oss och jag använder andra självgjorda laborationer som stämmer med vad vi hinner att läsa. De flesta laborationer görs grafiskt men i vissa tillfällen endast på kommandoprompten, CLI.

DHCP server

Bild 2: DHCP server-klient nätverkstrafik

Så här går det till när en dator lånar en IP adress:

När en dator startas eller ansluts till ett nätverk och om den är konfigurerad som DHCP-klient sänder ut en DHCP DISCOVER paket för att identifiera tillgängliga DHCP-servrar i nätverket. En DHCP-server (eller flera) kan svara med en DHCP OFFER paket som innehåller leasingofferten och andra IP parametrar.

Klienten väljer en server och sänder en DHCP REQUEST paket som innehåller leasingofferten klienten accepterar. Förutsatt att IP-adressen är fortfarande giltig returnerar servern en DHCP- ACK meddelande som bekräftelse. Men om adressen inte längre anses giltig sänder servern istället en DHCP-NACK och klienten måste starta om en ny leasingprocess.

DNS server

DNS är grundstenen för Internet eftersom den tjänsten hjälper oss att hitta resurser utsprida överallt. Alla servrar och alla nätverksenheter på Internet identifieras med ett namn och flera adresser. Namnet och adresser (IP) är med i DNS databasen som är också utsprida i världen. Resurserna finns på servrarna och de hittas med namn och adresser skrivna i binärt format som är svårt att använda för oss människor, vi föredrar bokstäver och decimala siffror istället. Det är här som DNS hjälper till och sammanbinder ihop namn och adresser.

DNS databasen körs i 13 logiska DNS servrar som i verkligheten är upp till 300 fysiska maskiner som är kända med sådana namn som Root Hints, Internet servers, mm. I databasen organiseras information om alla domäner och deras resurser som DNS resursposter (Resource Records) och det är de som konfigureras på lokala DNS servrar.

DNS konfiguration kräver kännedom av DNS resursposter eller DNS resource records. En av dessa poster är SOA record eller Start Of Authority som anger den primära DNS server på vilken en specifik domän körs.

HTTP server

Internet är fylld av webbservrar och i Packet Tracer kan simuleras hur de fungerar. Konfigurationer på HTTP server på Packet Tracer är enkla och inte nära till verkligheten, men det ger oss tillräckliga kunskaper på hur denna server fungerar tillsammans med andra nätverkstjänster. I dagens webbservrar krävs HTTPS för att vara med på Internet, det som ger detta protokoll är bland annat kryptering vilket innebär bättre säkerhet.

Konfigurationer

Till router R1 ansluts tre nätverk: MG Clients 10.10.10.0 /24; MG Core 20.20.20.0 /24; WAN 1 221.65.3.0 /30. Dessa nätverk ska programmeras in på router R1:

  • Router>enable
  • Router#configure terminal
  • Router(config)#hostname R1
  • R1(config)#interface g0/1
  • R1(config-if)#description LAN MG Clients
  • R1(config-if)#ip address 10.10.10.1 255.255.255.0
  • R1(config-if)#no shutdown
  • R1(config-if)#exit
  • R1(config)#interface g0/0
  • R1(config-if)#description LAN MG Core
  • R1(config-if)#ip address 20.20.20.1 255.255.255.0
  • R1(config-if)#no shutdown
  • R1(config-if)#exit
  • R1(config)#interface s0/0/0
  • R1(config-if)#description DCE Connected to R2
  • R1(config-if)#clock rate 128000
  • R1(config-if)#ip address 221.65.3.1 255.255.255.252
  • R1(config-if)#no shutdown
  • R1(config-if)#end
  • R1#show ip interface brief

Till router R2 ansluts två nätverk: WAN1: 221.65.3.0 /30 och WAN2: 81.32.1.0 /30. Dessa nätverk ska programmeras in på router R2:

  • Router>enable
  • Router#configure terminal
  • Router(config)#hostname R2
  • R2(config)#interface s0/0/0
  • R2(config-if)#description Connected to R1
  • R(config-if)#ip address 221.65.3.2 255.255.255.252
  • R2(config-if)#no shutdown
  • R2(config-if)#exit
  • R2(config)#interface s0/0/0
  • R2(config-if)#description DCE Connected to R3
  • R2(config-if)#clock rate 128000
  • R2(config-if)#ip address 81.32.1.2 255.255.255.252
  • R2(config-if)#no shutdown
  • R2(config-if)#end
  • R2#show ip interface brief

Till router R3 ansluts två nätverk: Diginto 172.16.1.0 /24 och 81.32.1.0 /30. Dessa nätverk ska programmeras in på router R3:

  • Router>enable
  • Router#configure terminal
  • Router(config)#hostname R3
  • R3(config)#interface g0/1
  • R3(config-if)#description LAN Diginto
  • R3(config-if)#ip address 172.16.1.1 255.255.255.252
  • R3(config-if)#no shutdown
  • R3(config)#interface s0/0/1
  • R3(config-if)#description Connected to R2
  • R3(config-if)#ip address 81.32.1.1 255.255.255.252
  • R3(config-if)#no shutdown
  • R3(config-if)#end
  • R3#show ip interface brief

Nätverkstopologin vi laborerar med har 5 nätverk vilket innebär att alla routrar ska ha information om fem nätverksadresser. Varje gång man konfigurerar routrar utgår man från routers perspektiv.

  • R1>enable
  • R1#configure terminal
  • R1(config)#ip route 81.32.1.0 255.255.255.252 221.65.3.2
  • R1(config)#ip route 172.16.1.0 255.255.255.0 221.65.3.2
  • R1(config)#end
  • R1#show ip route
  • R2
  • R2>enable
  • R2#configure terminal
  • R2(config)#ip route 10.10.10.0 255.255.255.0 221.65.3.1
  • R2(config)#ip route 20.20.20.0 255.255.255.0 221.65.3.1
  • R2(config)#ip route 172.16.1.0 255.255.255.0 81.32.1.1
  • R2(config)#end
  • R2#show ip route
  • R3
  • R3>enable
  • R3#configure terminal
  • R3(config)#ip route 221.65.3.0 255.255.255.252 81.32.1.2
  • R3(config)#ip route 10.10.10.0 255.255.255.0 81.32.1.2
  • R3(config)#ip route 20.20.20.0 255.255.255.0 81.32.1.2
  • R3(config)#end
  • R3#show ip route

DHCP server konfigureras grafiskt. Klicka på servern och därefter på fliken Services. Till vänster väljer du DHCP och till höger konfigurerar servern enligt bilden nedan:

  1. På fliken Services ska HTTP och HTTPS tjänster ska vara ON och alla andra tjänster OFF.
  2. Klicka på edit för att redigera filen index.html
  3. Redigera HTML texten enligt bilden och spara ändringen.

Bild 3: HTTP server, redigering av index.html filen
Bild 4: Hemsida på HTTP server

På ns1 i Diginto konfigureras en DNS server. Först ska du klicka på ns1 och därefter på Services. I Spalten till vänster väljer du DNS och på spalten till höger skaper du tre DNS resursposter, se bilden nedan: