Exempel 2

Här ska konfigureras olika statiska rutter.

Topologi

Bild 1: Statisk routing

Konfigurationer

  • R1 och R6 konfigureras som DHCP server
  • R1 till R2 en direkt anslutet statisk default rutt
  • R6 till R5 en direkt anslutet statisk default rutt
  • R2 rekursiva statiska rutter för 4.4.4.0 /30, 5.5.5.0 /30, 6.6.6.0 /30 och en aggregerad statisk rutt som inkluderar alla LAN anslutna till R6.
  • R2 en backup statisk rutt (floating route) via R4 mot den aggregerade rutt för R6
  • R5 rekursiva statiska rutter för 2.2.2.0 /30, 3.3.3.0 /30, 1.1.1.0 /30 och en aggregerad statisk rutt som inkluderar alla LAN anslutna till R1.
  • R5 en backup statisk rutt (floating route) via R4 mot den aggregerade rutt för R1
  • Router> enable
  • Router# configure terminal
  • Router(config)# hostname R1
  • R1(config) # no ip domain-lookup
  • R1(config) # interface Gig0/0
  • R1(config-if)# description Connected as DHCP server to LAN 1
  • R1(config-if)# ip address 172.1.11.254 255.255.252.0
  • R1(config-if)# no shutdown
  • R1(config-if)# exit
  • R1(config) # interface Gig0/1
  • R1(config-if)# description Connected as DHCP server to LAN 2
  • R1(config-if)# ip address 172.1.12.254 255.255.255.0
  • R1(config-if)# no shutdown
  • R1(config-if)# exit
  • R1(config) # interface Gig0/2
  • R1(config-if)# description Connected as DHCP server to LAN 3
  • R1(config-if)# ip address 172.1.13.30 255.255.255.224
  • R1(config-if)# no shutdown
  • R1(config-if)# exit
  • R1(config)# ip dhcp excluded-address 172.1.11.250 172.1.11.254
  • R1(config)# ip dhcp pool LAN1
  • R1(dhcp-config)# network 172.1.8.0 255.255.252.0
  • R1(dhcp-config)# default-router 172.1.11.254
  • R1(dhcp-config)# dns-server 8.8.8.8
  • R1(dhcp-config)# domain-name diginto.se
  • R1(dhcp-config)# exit
  • R1(config)# ip dhcp excluded-address 172.1.12.250 172.1.12.254
  • R1(config)# ip dhcp pool LAN2
  • R1(dhcp-config)# network 172.1.12.0 255.255.255.0
  • R1(dhcp-config)# default-router 172.1.12.254
  • R1(dhcp-config)# dns-server 8.8.8.8
  • R1(dhcp-config)# domain-name diginto.se
  • R1(dhcp-config)# exit
  • R1(config)# ip dhcp excluded-address 172.1.13.30
  • R1(config)# ip dhcp pool LAN3
  • R1(dhcp-config)# network 172.1.13.0 255.255.255.224
  • R1(dhcp-config)# default-router 172.1.13.30
  • R1(dhcp-config)# dns-server 8.8.8.8
  • R1(dhcp-config)# domain-name diginto.se
  • R1(dhcp-config)# exit
  • Router> enable
  • Router# configure terminal
  • Router(config)# hostname R1
  • R2(config) # no ip domain-lookup
  • R2(config) # interface s0/0/0
  • R2(config-if)# description Connected as DCE to R1
  • R2(config-if)# clock rate 2000000
  • R2(config-if)# ip address 1.1.1.2 255.255.255.252
  • R2(config-if)# no shutdown
  • R2(config-if)# exit
  • R2(config) # interface s0/0/1
  • R2(config-if)# description Connected as DCE to R3
  • R2(config-if)# clock rate 2000000
  • R2(config-if)# ip address 2.2.2.1 255.255.255.252
  • R2(config-if)# no shutdown
  • R2(config) # interface s0/1/0
  • R2(config-if)# description Connected as DCE to R4
  • R2(config-if)# clock rate 2000000
  • R2(config-if)# ip address 3.3.3.1 255.255.255.252
  • R2(config-if)# no shutdown
  • R2(config-if)# exit
  • R2(config)#
  • Router> enable
  • Router# configure terminal
  • Router(config)# hostname R3
  • R3(config)# no ip domain-lookup
  • R3(config)# interface s0/0/1
  • R3(config-if)# description Connected to R2
  • R3(config-if)# ip address 2.2.2.2 255.255.255.252
  • R3(config-if)# no shutdown
  • R3(config-if)# exit
  • R3(config)# interface s0/0/0
  • R3(config-if)# description Connected to R5
  • R3(config-if)# ip address 4.4.4.1 255.255.255.252
  • R3(config-if)# no shutdown
  • R3(config-if)# exit
  •  R3(config)#
  • Router> enable
  • Router# configure terminal
  • Router(config)# hostname R4
  • R4(config)# no ip domain-lookup
  • R4(config)# interface s0/0/1
  • R4(config-if)# description Connected to R2
  • R4(config-if)# ip address 3.3.3.2 255.255.255.252
  • R4(config-if)# no shutdown
  • R4(config-if)# exit
  • R4(config)# interface s0/0/0
  • R4(config-if)# description Connected to R5
  • R4(config-if)# ip address 5.5.5.1 255.255.255.252
  • R4(config-if)# no shutdown
  • R4(config-if)# exit
  •  R4(config)#
  • Router> enable
  • Router# configure terminal
  • Router(config)# hostname R5
  • R5(config)# no ip domain-lookup
  • R5(config)# interface s0/0/0
  • R5(config-if)# description Connected as DCE to R6
  • R5(config-if)# clock rate 2000000
  • R5(config-if)# ip address 6.6.6.1 255.255.255.252
  • R5(config-if)# no shutdow
  • R5(config-if)# exit
  • R5(config)# interface s0/0/1
  • R5(config-if)# description Connected as DCE to R3
  • R5(config-if)# clock rate 2000000
  • R5(config-if)# ip address 4.4.4.2 255.255.255.252
  • R5(config-if)# no shutdow
  • R5(config-if)# exit
  • R5(config)# interface s0/1/0
  • R5(config-if)# description Connected as DCE to R4
  • R5(config-if)# clock rate 2000000
  • R5(config-if)# ip address 5.5.5.2 255.255.255.252
  • R5(config-if)# no shutdow
  • R5(config-if)# exit
  • R5(config)# 
  • Router> enable
  • Router# configure terminal
  • Router(config)# hostname R6
  • R6(config)# no ip domain-lookup
  • R6(config)# interface s0/0/0
  • R6(config-if)# description Connected to R6
  • R6(config-if)# ip address 6.6.6.2 255.255.255.252
  • R6(config-if)# no shutdown
  • R6(config-if)#exit
  • R6(config)# interface Gig0/0
  • R6(config-if)# description Connected as DHCP server to LAN 4
  • R6(config-if)# ip address 192.168.11.254 255.255.252.0
  • R6(config-if)# no shutdown
  • R6(config-if)# exit
  • R6(config)# interface Gig0/1
  • R6(config-if)# description Connected as DHCP server to LAN 5
  • R6(config-if)# ip address 192.168.12.254 255.255.255.0
  • R6(config-if)# no shutdown
  • R6(config-if)# exit
  • R6(config)# interface Gig0/2
  • R6(config-if)# description Connected as DHCP server to LAN 6
  • R6(config-if)# ip address 192.168.13.30 255.255.255.224
  • R6(config-if)# no shutdown
  • R6(config-if)# exit
  • R6(config)# ip dhcp excluded-address 192.168.11.250 192.168.11.254
  • R6(config)# ip dhcp pool LAN4
  • R6(dhcp-config)# network 192.168.8.0 255.255.252.0
  • R6(dhcp-config)# default-router 192.168.11.254
  • R6(dhcp-config)# dns-server 8.8.8.8
  • R6(dhcp-config)# domain-name diginto.se
  • R6(dhcp-config)# exit
  • R6(config)# ip dhcp excluded-address 192.168.12.250 192.168.12.254
  • R6(config)# ip dhcp pool LAN5
  • R6(dhcp-config)# network 192.168.12.0 255.255.255.0
  • R6(dhcp-config)# default-router 192.168.12.254
  • R6(dhcp-config)# dns-server 8.8.8.8
  • R6(dhcp-config)# domain-name diginto.se
  • R6(dhcp-config)# exit
  • R6(config)# ip dhcp excluded-address 192.168.13.30
  • R6(config)# ip dhcp pool LAN6
  • R6(dhcp-config)# network 192.168.13.0 255.255.255.224
  • R6(dhcp-config)# default-router 192.168.13.30
  • R6(dhcp-config)# dns-server 8.8.8.8
  • R6(dhcp-config)# domain-name diginto.se
  • R6(dhcp-config)# exit
  • R6(config)#
  • IP adressaggregering - R1 LAN1, LAN2 och LAN3:
  • 172.1.8.0 722 - - - - - 0000 1000
  • 172.1.12.0 /24  - - - - 0000 1100
  • 172.1.13.0 /27 - - - -  0000 1101
  • 172.1.8.0 /21 dvs 255.255.248.0
  • IP adressaggregering - R6 LAN4, LAN5 och LAN6
  • 192.168.8.0 /22 - - - -  0000 1000
  • 192.168.12.0 /24- - - - 0000 1100
  • 192.168.13.0 /27- - - - 0000 1100
  • 192.168.8.0 /21 dvs 255.255.248.0
  • R1(config)# ip route 0.0.0.0 0.0.0.0 s0/0/0
  • R2(config)# ip route 172.1.8.0 255.255.248.0 1.1.1.1
  • R2(config)# ip route 4.4.4.0 255.255.255.252 2.2.2.2
  • R2(config)# ip route 5.5.5.5 255.255.255.252 3.3.3.2
  • R2(config)# ip route 6.6.6.0 255.255.248.0 2.2.2.2
  • R2(config)# ip route 192.168.8.0 255.255.248.0 2.2.2.2
  • R2(config)# ip route 192.168.8.0 255.255.248.0 3.3.3.2 5
  • R3(config)# ip route 1.1.1.0 255.255.255.252 2.2.2.1
  • R3(config)# ip route 172.1.8.0 255.255.248.0 2.2.2.1
  • R3(config)# ip route 3.3.3.0 255.255.255.252 2.2.2.1
  • R3(config)# ip route 6.6.6.0 255.255.255.252 4.4.4.2
  • R3(config)# ip route 192.168.8.0 255.255.248.0 4.4.4.2
  • R3(config)# ip route 5.5.5.0 255.255.255.252 4.4.4.2
  • R4(config)# ip route 1.1.1.0 255.255.255.252 3.3.3.1
  • R4(config)# ip route 172.1.8.0 255.255.248.0 3.3.3.1
  • R4(config)# ip route 2.2.2.0 255.255.255.252 3.3.3.1
  • R4(config)# ip route 4.4.4.0 255.255.255.252 5.5.5.2
  • R4(config)# ip route 6.6.6.0 255.255.255.252 5.5.5.2
  • R4(config)# ip route 192.168.8.0 255.255.248.0 5.5.5.2
  • R5(config)# ip route 192.168.8.0 255.255.248.0 6.6.6.2
  • R5(config)# ip route 2.2.2.0 255.255.255.252 4.4.4.1
  • R5(config)# ip route 1.1.1.0 255.255.255.252 4.4.4.1
  • R5(config)# ip route 3.3.3.0 255.255.255.252 5.5.5.1
  • R5(config)# ip route 172.1.8.0 255.255.248.0 4.4.4.1
  • R5(config)# ip route 172.1.8.0 255.255.248.0 5.5.5.1 5
  • R6(config)# ip route 0.0.0.0 0.0.0.0 s0/0/0